$re = '@.*DATE \d{2}/\d{2}/\d{4}(?|"(.*)".*|(.*))|.+@m';
$str = 'LAW Nº 1234/1998 - DATE 01/01/1998"LAW TITLE HERE MAY CONTAIN 4|_|D4NUM3R!C OR P_NC7U@7|()N".
LAW Nº 1234/1998 - DATE 01/01/1998LAW TITLE HERE MAY CONTAIN 4|_|D4NUM3R!C OR P_NC7U@7|()N
something that does not match';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;