use strict;
my $str = 'LAW Nº 1234/1998 - DATE 01/01/1998"LAW TITLE HERE MAY CONTAIN 4|_|D4NUM3R!C OR P_NC7U@7|()N".
LAW Nº 1234/1998 - DATE 01/01/1998LAW TITLE HERE MAY CONTAIN 4|_|D4NUM3R!C OR P_NC7U@7|()N
something that does not match';
my $regex = qr@.*DATE \d{2}/\d{2}/\d{4}(?|"(.*)".*|(.*))|.+@mp;
my $subst = '$1';
my $result = $str =~ s@$regex@$subst@rg;
print "The result of the substitution is' $result\n";