const regex = new RegExp('.*DATE \\d{2}/\\d{2}/\\d{4}(?|"(.*)".*|(.*))|.+', 'gm')
const str = `LAW Nº 1234/1998 - DATE 01/01/1998"LAW TITLE HERE MAY CONTAIN 4|_|D4NUM3R!C OR P_NC7U@7|()N".
LAW Nº 1234/1998 - DATE 01/01/1998LAW TITLE HERE MAY CONTAIN 4|_|D4NUM3R!C OR P_NC7U@7|()N
something that does not match`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);