# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*DATE \d{2}/\d{2}/\d{4}(?|\"(.*)\".*|(.*))|.+"
test_str = ("LAW Nº 1234/1998 - DATE 01/01/1998\"LAW TITLE HERE MAY CONTAIN 4|_|D4NUM3R!C OR P_NC7U@7|()N\".\n"
"LAW Nº 1234/1998 - DATE 01/01/1998LAW TITLE HERE MAY CONTAIN 4|_|D4NUM3R!C OR P_NC7U@7|()N\n"
"something that does not match")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.