package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*DATE \d{2}/\d{2}/\d{4}(?|"(.*)".*|(.*))|.+`)
var str = `LAW Nº 1234/1998 - DATE 01/01/1998"LAW TITLE HERE MAY CONTAIN 4|_|D4NUM3R!C OR P_NC7U@7|()N".
LAW Nº 1234/1998 - DATE 01/01/1998LAW TITLE HERE MAY CONTAIN 4|_|D4NUM3R!C OR P_NC7U@7|()N
something that does not match`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}