#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?=(\.[^.]*){3}$)\.(.{3})"
Local $sString = "aaa.bbbb.ccc4.ddd1.eee.fff" & @CRLF & _
"1112.2223.333.4445.555.6661.7773.8881.999"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)