re = /(?=(\.[^.]*){3}$)\.(.{3})/m
str = 'aaa.bbbb.ccc4.ddd1.eee.fff
1112.2223.333.4445.555.6661.7773.8881.999'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result