const regex = /(?=(\.[^.]*){3}$)\.(.{3})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(\\.[^.]*){3}$)\\.(.{3})', 'gm')
const str = `aaa.bbbb.ccc4.ddd1.eee.fff
1112.2223.333.4445.555.6661.7773.8881.999`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);