import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(\\.[^.]*){3}$)\\.(.{3})";
final String string = "aaa.bbbb.ccc4.ddd1.eee.fff\n"
+ "1112.2223.333.4445.555.6661.7773.8881.999";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}