$re = '/(?=(\.[^.]*){3}$)\.(.{3})/m';
$str = 'aaa.bbbb.ccc4.ddd1.eee.fff
1112.2223.333.4445.555.6661.7773.8881.999';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;