use strict;
my $str = 'aaa.bbbb.ccc4.ddd1.eee.fff
1112.2223.333.4445.555.6661.7773.8881.999';
my $regex = qr/(?=(\.[^.]*){3}$)\.(.{3})/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";