#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s).+? (?<name>.+) \((?<points>\d+) points?\)\n(?:When input is\n(?<input>.*?)\n)?Standard output (?<condition>.+?)\n(?<output>.+)\nEdit\nClone\nRemove\n"
Local $sString = ""1. Compare output (2 points)" & @CRLF & _
"Standard output exactly matches" & @CRLF & _
"Character 'p' is a letter" & @CRLF & _
"Character ' ' is a white space" & @CRLF & _
"Character '2' is a digit" & @CRLF & _
"Character '!' is unknown" & @CRLF & _
"" & @CRLF & _
"Edit" & @CRLF & _
"Clone" & @CRLF & _
"Remove" & @CRLF & _
"" & @CRLF & _
"----" & @CRLF & _
"" & @CRLF & _
"1. Compare output (2 points)" & @CRLF & _
"When input is" & @CRLF & _
"xxxtoyxxx" & @CRLF & _
"Standard output exactly matches" & @CRLF & _
"Midfix: toy" & @CRLF & _
"" & @CRLF & _
"Edit" & @CRLF & _
"Clone" & @CRLF & _
"Remove"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")