package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s).+? (?<name>.+) \((?<points>\d+) points?\)\n(?:When input is\n(?<input>.*?)\n)?Standard output (?<condition>.+?)\n(?<output>.+)\nEdit\nClone\nRemove\n`)
var str = `"1. Compare output (2 points)
Standard output exactly matches
Character 'p' is a letter
Character ' ' is a white space
Character '2' is a digit
Character '!' is unknown
Edit
Clone
Remove
----
1. Compare output (2 points)
When input is
xxxtoyxxx
Standard output exactly matches
Midfix: toy
Edit
Clone
Remove`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}