$re = '/.+? (?<name>.+) \((?<points>\d+) points?\)\n(?:When input is\n(?<input>.*?)\n)?Standard output (?<condition>.+?)\n(?<output>.+)\nEdit\nClone\nRemove\n/s';
$str = '"1. Compare output (2 points)
Standard output exactly matches
Character \'p\' is a letter
Character \' \' is a white space
Character \'2\' is a digit
Character \'!\' is unknown
Edit
Clone
Remove
----
1. Compare output (2 points)
When input is
xxxtoyxxx
Standard output exactly matches
Midfix: toy
Edit
Clone
Remove';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);