using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+? (?<name>.+) \((?<points>\d+) points?\)\n(?:When input is\n(?<input>.*?)\n)?Standard output (?<condition>.+?)\n(?<output>.+)\nEdit\nClone\nRemove\n";
string input = @"""1. Compare output (2 points)
Standard output exactly matches
Character 'p' is a letter
Character ' ' is a white space
Character '2' is a digit
Character '!' is unknown
Edit
Clone
Remove
----
1. Compare output (2 points)
When input is
xxxtoyxxx
Standard output exactly matches
Midfix: toy
Edit
Clone
Remove";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}