using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^(?!.*bar).*)| ";
string substitution = @"\1\t";
string input = @"foo: here is some sample text
bar: here is some sample text";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}