use strict;
my $str = 'foo: here is some sample text
bar: here is some sample text';
my $regex = qr/(^(?!.*bar).*)| /mp;
my $subst = '\\1\\t';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";