re = /(^(?!.*bar).*)| /m
str = 'foo: here is some sample text
bar: here is some sample text'
subst = '\\1\\t'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result