const regex = /(^(?!.*bar).*)| /gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^(?!.*bar).*)| ', 'gm')
const str = `foo: here is some sample text
bar: here is some sample text`;
const subst = `\1\t`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);