$re = '/(^(?!.*bar).*)| /m';
$str = 'foo: here is some sample text
bar: here is some sample text';
$subst = "\1\t";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;