#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z](?!\w*__)(?:\w*[^\W_])?$"
Local $sString = "somestring" & @CRLF & _
"_not_this_one" & @CRLF & _
"thisone_" & @CRLF & _
"neither this one" & @CRLF & _
"but_this_one" & @CRLF & _
"this__one_not" & @CRLF & _
"this_one__yes" & @CRLF & _
"a" & @CRLF & _
"b" & @CRLF & _
"cd" & @CRLF & _
"c_" & @CRLF & _
"c__d" & @CRLF & _
"c_d"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")