re = /^[a-z](?!\w*__)(?:\w*[^\W_])?$/m
str = 'somestring
_not_this_one
thisone_
neither this one
but_this_one
this__one_not
this_one__yes
a
b
cd
c_
c__d
c_d'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end