using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z](?!\w*__)(?:\w*[^\W_])?$";
string input = @"somestring
_not_this_one
thisone_
neither this one
but_this_one
this__one_not
this_one__yes
a
b
cd
c_
c__d
c_d";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}