use strict;
my $str = 'somestring
_not_this_one
thisone_
neither this one
but_this_one
this__one_not
this_one__yes
a
b
cd
c_
c__d
c_d';
my $regex = qr/^[a-z](?!\w*__)(?:\w*[^\W_])?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}