import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z](?!\\w*__)(?:\\w*[^\\W_])?$";
final String string = "somestring\n"
+ "_not_this_one\n"
+ "thisone_\n"
+ "neither this one\n"
+ "but_this_one\n"
+ "this__one_not\n"
+ "this_one__yes\n"
+ "a\n"
+ "b\n"
+ "cd\n"
+ "c_\n"
+ "c__d\n"
+ "c_d";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}