package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^service\/([^\/])(.*)\/vdnh\/?$`)
var str = `service/bla-bla/blu-blu-bli/
service/bla-bla/blu-blu-bli/qwerty/
service/bla-bla/blu-blu-bli/qwerty/page44/
service/bla-bla/blu-blu-bli/vdnh/
service/bla-bla/blu-blu-bli/qwerty/page44/vdnh`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}