re = /^service\/([^\/])(.*)\/vdnh\/?$/m
str = 'service/bla-bla/blu-blu-bli/
service/bla-bla/blu-blu-bli/qwerty/
service/bla-bla/blu-blu-bli/qwerty/page44/
service/bla-bla/blu-blu-bli/vdnh/
service/bla-bla/blu-blu-bli/qwerty/page44/vdnh'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end