import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^service\\/([^\\/])(.*)\\/vdnh\\/?$";
final String string = "service/bla-bla/blu-blu-bli/\n"
+ "service/bla-bla/blu-blu-bli/qwerty/\n"
+ "service/bla-bla/blu-blu-bli/qwerty/page44/\n"
+ "service/bla-bla/blu-blu-bli/vdnh/\n"
+ "service/bla-bla/blu-blu-bli/qwerty/page44/vdnh";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}