// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^service\/([^\/])(.*)\/vdnh\/?$").unwrap();
let string = "service/bla-bla/blu-blu-bli/
service/bla-bla/blu-blu-bli/qwerty/
service/bla-bla/blu-blu-bli/qwerty/page44/
service/bla-bla/blu-blu-bli/vdnh/
service/bla-bla/blu-blu-bli/qwerty/page44/vdnh";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}