#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)key\": \"material\",.*?\"value\": \"(.*?)\","
Local $sString = "{" & @CRLF & _
" "key": "width"," & @CRLF & _
" "value": "1200"," & @CRLF & _
" "label": "Width (mm)"," & @CRLF & _
" "choice": """ & @CRLF & _
"}," & @CRLF & _
"{" & @CRLF & _
" "key": "height"," & @CRLF & _
" "value": "900"," & @CRLF & _
" "label": "Height (mm)"," & @CRLF & _
" "choice": """ & @CRLF & _
"}," & @CRLF & _
"{" & @CRLF & _
" "key": "material"," & @CRLF & _
" "value": "paper"," & @CRLF & _
" "label": "Material"," & @CRLF & _
" "choice": "Paper"" & @CRLF & _
"}]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")