// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)key\": \"material\",.*?\"value\": \"(.*?)\","#).unwrap();
let string = "{
\"key\": \"width\",
\"value\": \"1200\",
\"label\": \"Width (mm)\",
\"choice\": \"\"
},
{
\"key\": \"height\",
\"value\": \"900\",
\"label\": \"Height (mm)\",
\"choice\": \"\"
},
{
\"key\": \"material\",
\"value\": \"paper\",
\"label\": \"Material\",
\"choice\": \"Paper\"
}]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}