import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "key\\\": \\\"material\\\",.*?\\\"value\\\": \\\"(.*?)\\\",";
final String string = "{\n"
+ " \"key\": \"width\",\n"
+ " \"value\": \"1200\",\n"
+ " \"label\": \"Width (mm)\",\n"
+ " \"choice\": \"\"\n"
+ "},\n"
+ "{\n"
+ " \"key\": \"height\",\n"
+ " \"value\": \"900\",\n"
+ " \"label\": \"Height (mm)\",\n"
+ " \"choice\": \"\"\n"
+ "},\n"
+ "{\n"
+ " \"key\": \"material\",\n"
+ " \"value\": \"paper\",\n"
+ " \"label\": \"Material\",\n"
+ " \"choice\": \"Paper\"\n"
+ "}]";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}