package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)key\": \"material\",.*?\"value\": \"(.*?)\",`)
var str = `{
"key": "width",
"value": "1200",
"label": "Width (mm)",
"choice": ""
},
{
"key": "height",
"value": "900",
"label": "Height (mm)",
"choice": ""
},
{
"key": "material",
"value": "paper",
"label": "Material",
"choice": "Paper"
}]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}