re = /key\": \"material\",.*?\"value\": \"(.*?)\",/
str = '{
"key": "width",
"value": "1200",
"label": "Width (mm)",
"choice": ""
},
{
"key": "height",
"value": "900",
"label": "Height (mm)",
"choice": ""
},
{
"key": "material",
"value": "paper",
"label": "Material",
"choice": "Paper"
}]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end