using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"key\"": \""material\"",.*?\""value\"": \""(.*?)\"",";
string input = @"{
""key"": ""width"",
""value"": ""1200"",
""label"": ""Width (mm)"",
""choice"": ""
},
{
""key"": ""height"",
""value"": ""900"",
""label"": ""Height (mm)"",
""choice"": ""
},
{
""key"": ""material"",
""value"": ""paper"",
""label"": ""Material"",
""choice"": ""Paper""
}]";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}