using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/)(?:[A-Z2-7]{8})*(?:[A-Z2-7]{2}={6}|[A-Z2-7]{4}={4}|[A-Z2-7]{5}={3}|[A-Z2-7]{7}=)?(\/|$)|(\/)(\d*?)(\/|$)";
string substitution = @"/";
string input = @"/emrc/patient/123";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}