use strict;
my $str = '/emrc/patient/123';
my $regex = qr/(\/)(?:[A-Z2-7]{8})*(?:[A-Z2-7]{2}={6}|[A-Z2-7]{4}={4}|[A-Z2-7]{5}={3}|[A-Z2-7]{7}=)?(\/|$)|(\/)(\d*?)(\/|$)/p;
my $subst = '/';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";