package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\/)(?:[A-Z2-7]{8})*(?:[A-Z2-7]{2}={6}|[A-Z2-7]{4}={4}|[A-Z2-7]{5}={3}|[A-Z2-7]{7}=)?(\/|$)|(\/)(\d*?)(\/|$)`)
var str = []byte(`/emrc/patient/123`)
var substitution = []byte("/")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}