re = /(\/)(?:[A-Z2-7]{8})*(?:[A-Z2-7]{2}={6}|[A-Z2-7]{4}={4}|[A-Z2-7]{5}={3}|[A-Z2-7]{7}=)?(\/|$)|(\/)(\d*?)(\/|$)/
str = '/emrc/patient/123'
subst = '/'
result = str.sub(re, subst)
# Print the result of the substitution
puts result