# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b-/\n/gm;t' <<< "Description 2--340-20
-2
-2---2---3-
@#$-@$#-@#$-"