re = /\b-/m
str = 'Description 2--340-20
-2
-2---2---3-
@#$-@$#-@#$-'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result