use strict;
my $str = 'Description 2--340-20
-2
-2---2---3-
@#$-@$#-@#$-';
my $regex = qr/\b-/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";