const regex = new RegExp('\\b-', 'gm')
const str = `Description 2--340-20
-2
-2---2---3-
@#\$-@\$#-@#\$-`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);