$re = '/\b-/m';
$str = 'Description 2--340-20
-2
-2---2---3-
@#$-@$#-@#$-';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;