# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/p-col-(\d+)/col-$1/gm;t' <<< "<div class=\"p-grid forms-grid\">
<div class=\"p-col-12 p-md-6\">
<div>InputText</div>
<input pInputText type=\"text\" />
</div>
<div class=\"p-col-12 p-md-6\">
<div>Textarea</div>
<textarea pInputTextarea type=\"text\"></textarea>
</div>"