import Foundation
let pattern = #"p-col-(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<div class="p-grid forms-grid">
<div class="p-col-12 p-md-6">
<div>InputText</div>
<input pInputText type="text" />
</div>
<div class="p-col-12 p-md-6">
<div>Textarea</div>
<textarea pInputTextarea type="text"></textarea>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"col-$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)