package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)p-col-(\d+)`)
var str = `<div class="p-grid forms-grid">
<div class="p-col-12 p-md-6">
<div>InputText</div>
<input pInputText type="text" />
</div>
<div class="p-col-12 p-md-6">
<div>Textarea</div>
<textarea pInputTextarea type="text"></textarea>
</div>`
var substitution = "col-$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}