$re = '/p-col-(\d+)/m';
$str = '<div class="p-grid forms-grid">
<div class="p-col-12 p-md-6">
<div>InputText</div>
<input pInputText type="text" />
</div>
<div class="p-col-12 p-md-6">
<div>Textarea</div>
<textarea pInputTextarea type="text"></textarea>
</div>';
$subst = "col-$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;