use strict;
my $str = '<div class="p-grid forms-grid">
<div class="p-col-12 p-md-6">
<div>InputText</div>
<input pInputText type="text" />
</div>
<div class="p-col-12 p-md-6">
<div>Textarea</div>
<textarea pInputTextarea type="text"></textarea>
</div>';
my $regex = qr/p-col-(\d+)/mp;
my $subst = 'col-$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";