// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)p-col-(\d+)").unwrap();
let string = "<div class=\"p-grid forms-grid\">
<div class=\"p-col-12 p-md-6\">
<div>InputText</div>
<input pInputText type=\"text\" />
</div>
<div class=\"p-col-12 p-md-6\">
<div>Textarea</div>
<textarea pInputTextarea type=\"text\"></textarea>
</div>";
let substitution = "col-$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}